Home e-Manual

Bluetooth dongle connection to CM-550

I have the Bluetooth dongle that came with the Engineer kit 2. I am now trying to do a wireless connection between my PC and the CM-550.

I followed the instruction here https://emanual.robotis.com/docs/en/parts/communication/bt-410-dongle/

The dongle shows us as a USB serial on my windows device manger. I opened a putty terminal and set keyboard echo on then typed in the commands in the instruction and got the correct response back and the dongle stopped flashing blue and tuned solid blue like it is connected to the CM-550

When I go back to Task IDE and try to connect to the CM-550 by the Bluetooth connection it fails to connect.

How can I make it work??

I seem to have made it work now, not sure what I did different.

It doesn’t seem to auto connect though and I seem to have open a putty terminal and manually connect it each time. Do others have the same problem??

1 Like

I think that it may be a Windows OS thing: once a COM Port is used by one app, Windows won’t let another app use the same port at the same time. The user has to exit the first app completely before using that COM port again.

@roboteer yes this is correct for windows (linux does allow many apps to use the same port).

When you use the Bluetooth dongle do you need to manually connect it to the CM-550 with AT commands each time you power it on or does it auto connect for you??

So far I have used the BT-410 dongle only with ROBOTIS software such as MANAGER and TASK, and not with a plain Serial Terminal, so I never had to use any AT command.

@roboteer
For me the BT-410 just flashes blue when I plug it in. If open up TASK app it sees the com port of the BT-410 dongle but if I click on connect it doesn’t connect. I have to first open up a putty terminal and use AT commands to get it to pair to the CM-550 and the blue light stops flashing and remains solid then I can close putty and open TASK and TASK will then connect.

@Out_of_the_BOTS
I think that I know what is going on now. :grinning:
That BT-410 Dongle is a bridge device, it will pair automatically with any BT-410 receiver like the embedded one on the CM-550 - BUT you have to get the dongle to about 1-2 inches from the CM-550 for it to pair automatically the FIRST time. Afterwards it will pair from “regular” distances. Also, that BT-410 dongle will work with any other CM-550 if you have more than one, but only one at a time of course and using the 1-2 inches distance at first pairing.

1 Like

Ok I tried putting the CM-550 right next to the dongle after I plugged it in and now it connects correctly.

Thanks @roboteer