Home e-Manual

Issues with Dynamixel AX-18A and Arduino DUE board

related hardware and servos:

  • AX-18A
  • Dynamixel Shield (not MKR series)
  • Arduino DUE

software:

  • Arduino IDE (ver 1.8.19)
  • Mac

I am working on a project that uses Dynamixel AX-18A and I want to use an Arduino Due board with a Dynamixel shield. While I am able to upload the code without errors or complications, the motor is unresponsive. The code I initially tried uploading to ensure everything was working as predicted with the velocity-mode and position-mode examples provided by the Dynamixel2Arduino library. However, neither caused motor movement. I have used the Dynamixel Wizard to confirm the motors are working properly. Previously, I had used the Arduino MEGA board with the same motors I’m currently using and I did not have issues controlling the motors. I’ve only come into issues when I’ve swapped out the Arduino MEGA with the Arduino DUE. The hardware I’m using is the Programming Port of the Arduino DUE and connecting the power supply through the Dynamixel Shield. My end goal would be to use this set up to control 6 different motors synchronously, but I haven’t been able to get it to work with a single motor yet. Are there any suggestions on how to fix this issue?

It looks like the DUE is only officially compatible with 3.3v Shields. The DYNAMIXEL Shield operates at a minimal of 5v. There is likely some way to add additional hardware to convert the voltage levels to enable interoperability, but this difference is likely why the shield is not functioning correctly out of the box.